Feeds:
Posts
Comments

Archive for the ‘General’ Category

For a suggestion of one of my teachers (Danny Abesdris) I decide to try Komodo Editor 5, he showed us this tool and I liked it, as a programmer I’m always attracted by having available features like call tips, autocomplete, syntax colouring and syntax checking because in easier to learn in that way.

Komodo Editor has other capabilities like multi-language file support (Perl, PHP, Python, CSS, HTML, JavaScript, XML… etc),¬† Vi emulation among some others things (that I guess will be able to discover very soon).

So, I downloaded it from:  http://www.activestate.com/komodo_edit/

I got the tarball, unzipped it, run the install.sh script… but I got this message:

chcon: unrecognized option ‘–quiet’
Try `chcon –help’ for more information.
chcon: unrecognized option ‘–quiet’
Try `chcon –help’ for more information.
chcon: unrecognized option ‘–quiet’
Try `chcon –help’ for more information.
chcon: unrecognized option ‘–quiet’
Try `chcon –help’ for more information.
install: error: could not set SELinux security context for ‘/home/Patty/Komodo-Edit-5/lib/python/lib/libpython2.6.so’: ‘texrel_shlib_t’, ‘textrel_shlib_t’, ‘shlib_t’, ‘s0’ contexts failed

To fix the problem it necessary¬† just make a small change in the file: selinuxlib.py (which is in the installation package directory, inside of “support” directory) in this line:

cmd = ‘chcon -t %s –quiet “%s”‘ % (context, path)

to make it like this:

cmd = ‘chcon -t %s “%s”‘ % (context, path)

and it will works without any problems.

So if somebody want to try it and get same trouble, just need to try this.

Read Full Post »